Bitcard: The Bitcoin Gift Card USD: redemption errors
Incident Report for NeoCurrency
Resolved
This incident is now resolved. The customers can just click the reward link to redeem.
Posted Mar 17, 2023 - 15:46 UTC
Investigating
We are investigating the redemption issue with Bitcard: The Bitcoin Gift Cards USD. We will reset any failed redemptions after the issue is resolved.
Posted Mar 16, 2023 - 12:32 UTC
This incident affected: NeoCurrency Rewards.