Swiggy INR: temporarily unavailable

Incident Report for NeoCurrency

Resolved

Swiggy INR reward is available now. Customers can just click the links again to redeem.
Posted Mar 17, 2026 - 15:23 UTC

Identified

Swiggy INR reward is temporarily unavailable. We will update as soon as the brand is back.
Posted Mar 12, 2026 - 05:36 UTC
This incident affected: NeoCurrency Rewards.