Express USD: discontinued
Incident Report for NeoCurrency
Resolved
This incident has been resolved.
Posted Apr 25, 2024 - 02:47 UTC
Investigating
Express USD reward is being discontinued as the brand has filed for bankruptcy. The brand is no longer available in our catalog.
Posted Apr 24, 2024 - 16:47 UTC
This incident affected: NeoCurrency Rewards.