Starbucks KRW: out of stock
Incident Report for NeoCurrency
Resolved
Starbucks ₩4500, 4900, 5000, 5900 KRW denominations are discontinued. Available denominations are 10,000, 20,000, 30,000 and 50,000 KRW.
Posted Jan 09, 2025 - 09:56 UTC
Investigating
Starbucks ₩4500, 4900, 5000, 5900 KRW denominations are out of stock. We will update as soon as the denominations are available again.
Posted Aug 30, 2024 - 04:43 UTC
This incident affected: NeoCurrency Rewards.