Nike USD: order error
Incident Report for NeoCurrency
Resolved
Nike USD orders are working fine now. Customers can just click their reward links again to redeem.
Posted Mar 06, 2024 - 16:30 UTC
Investigating
Nike USD orders are failing. We are looking into the issue and will update as soon as it is resolved.
Posted Mar 06, 2024 - 05:52 UTC
This incident affected: NeoCurrency Rewards.