Carrefour ES EUR: temporarily unavailable

Incident Report for NeoCurrency

Resolved

Carrefour ES EUR reward is back. Customers can just click the links again to redeem.
Posted Mar 11, 2026 - 05:57 UTC

Identified

Carrefour ES EUR reward is temporarily unavailable. We will update as soon as the brand is back.
Posted Mar 09, 2026 - 06:45 UTC
This incident affected: NeoCurrency Rewards.