DANA IDR: temporarily unavailable

Incident Report for NeoCurrency

Resolved

DANA IDR rewards are working fine now. Customers can just click the reward links again to redeem.
Posted Mar 28, 2025 - 13:18 UTC

Identified

DANA IDR brand is temporarily unavailable. We will let you know as soon as the brand is available.
Posted Mar 28, 2025 - 13:05 UTC
This incident affected: NeoCurrency Rewards.