Walmart USD order errors
Incident Report for NeoCurrency
Resolved
Walmart USD orders are working fine now. Customers can just click the links again to redeem.
Posted Jul 20, 2024 - 01:23 UTC
Investigating
Walmart USD orders are failing. We are looking into the issue and will update as soon as it is resolved.
Posted Jul 19, 2024 - 12:44 UTC
This incident affected: NeoCurrency Rewards.