Indigo CAD: orders failing
Incident Report for NeoCurrency
Resolved
Indigo CAD orders are working fine now. Customers can just click the reward links again to redeem.
Posted Feb 04, 2024 - 14:14 UTC
Investigating
Indigo CAD orders are failing. We are working with the brand processor regarding the error and will confirm as soon as it is resolved.
Posted Feb 02, 2024 - 12:32 UTC
This incident affected: NeoCurrency Rewards.