Identified – API and Reward Redemption Disruption

Incident Report for NeoCurrency

Update

Affected brands are Apple USD, Razer Gold USD, Roblox USD, Xbox USD and all EUR products.
Posted Aug 16, 2026 - 02:00 UTC

Identified

On August 15, 2026, NeoCurrency experienced a service disruption affecting portions of our platform and reward redemption services.
During this period, customers may have experienced degraded platform performance, including longer-than-normal API response times and the temporary inability to complete reward conversions for certain brands.

As of 3:40 PM ET on August 15, overall API and platform performance has returned to normal operating levels.

Reward redemptions for select brands remain temporarily unavailable or may experience intermittent availability. Our team is actively working to restore full redemption functionality and currently expects these remaining issues to be resolved by the morning of August 17.

We continue to closely monitor platform performance and restoration efforts.

We apologize for the disruption and appreciate your patience. We will provide additional updates as appropriate.
Posted Aug 16, 2026 - 00:15 UTC
This incident affects: NeoCurrency Reward API, NeoCurrency Reward Dashboard, and NeoCurrency Rewards.