Reward Link Availability Update

Incident Report for NeoCurrency

Update

We are continuing to investigate this issue.
Posted Aug 24, 2026 - 08:29 UTC

Investigating

Some previously issued reward links may no longer be active following platform performance corrections completed last week.
Please contact Reward Manager if a reward link is not working and our team will promptly review the request and work with you to restore or replace affected rewards, as appropriate.
Posted Aug 24, 2026 - 08:29 UTC
This incident affects: NeoCurrency Reward API, NeoCurrency Reward Dashboard, and NeoCurrency Rewards.