Decathlon BE EUR: unavailable

Incident Report for NeoCurrency

Resolved

Decathlon BE EUR reward has been discontinued with immediate effect. Please remove the brand from your catalog.
Posted Mar 17, 2026 - 15:24 UTC

Identified

Decathlon BE EUR reward is unavailable. We will update as soon as we receive more information.
Posted Mar 13, 2026 - 05:10 UTC
This incident affected: NeoCurrency Rewards.