PlayStation Plus CAD: discontinued
Incident Report for NeoCurrency
Resolved
This incident has been resolved.
Posted Mar 05, 2024 - 06:40 UTC
Investigating
PlayStation Plus CAD is discontinued with immediate effect. Orders can be placed on the alternative brand PlayStation Store CAD, which is available in denominations $10, $25, $60, $75 and $100 CAD.
Posted Mar 05, 2024 - 06:40 UTC
This incident affected: NeoCurrency Rewards.