Apple EUR, CHF and GBP order errors

Incident Report for NeoCurrency

Resolved

Apple EUR, CHF and GBP orders are working fine now. Customers can just click the reward links again to redeem.
Posted Mar 05, 2025 - 15:27 UTC

Identified

Apple EUR, CHF and GBP orders are failing. We will let you know as soon as the issue is resolved.
Posted Mar 03, 2025 - 15:33 UTC
This incident affected: NeoCurrency Rewards.