PTG THB: discontinued

Incident Report for NeoCurrency

Resolved

PTG THB reward has been discontinued with immediate effect. Please remove the brand from your catalog.
Posted Sep 16, 2026 - 07:12 UTC

Identified

PTG THB reward is temporarily unavailable. We will update as soon as the brand is back.
Posted Sep 09, 2026 - 20:49 UTC

Investigating

PTG THB reward is temporarily unavailable. We will update as soon as the brand is back.
Posted Sep 09, 2026 - 20:45 UTC
This incident affected: NeoCurrency Rewards.