Spotify USD denominations change notification

Incident Report for NeoCurrency

Update

The Spotify USD denominations $10, $30 and $60 are no longer available. Please remove them from your catalog immediately.
Posted Mar 21, 2025 - 09:20 UTC

Identified

We would like to inform you that there is a change in the denominations for the Spotify USD subscription brand.

Here are the new denominations.

Current Denomination New Denomination
Spotify 1 month $10 $12
Spotify 3 month $30 $36
Spotify 6 month $60 $72

The current denominations will not be available from March 21, 2025. We request you to remove the current denominations from your catalog before March 21, 2025.

The new denominations will be available from April 1, 2025.
Posted Mar 14, 2025 - 11:54 UTC
This incident affects: NeoCurrency Rewards.