CDON FI EUR: temporarily discontinued

Incident Report for NeoCurrency

Update

We are continuing to work on a fix for this issue.
Posted Feb 11, 2025 - 10:31 UTC

Identified

CDON FI EUR brand is temporarily discontinued. Please remove the brand from your catalog. We will update as soon as the brand is available.
Posted Feb 11, 2025 - 10:30 UTC
This incident affects: NeoCurrency Rewards.