Jumia EGP: temporarily out of stock
Incident Report for NeoCurrency
Resolved
Jumia EGP is back in stock. Customers can just click the links again to redeem.
Posted Apr 04, 2024 - 06:36 UTC
Investigating
Jumia EGP is temporarily out of stock. We will let you know as soon as the brand is available again.
Posted Mar 19, 2024 - 17:38 UTC
This incident affected: NeoCurrency Rewards.