Habitt 20,000 PKR: unavailable

Incident Report for NeoCurrency

Resolved

Habitt 20,000 PKR denomination has been discontinued. Kindly remove this denomination from your catalog. Available denominations are 2500, 5000 and 10000 PKR.
Posted Mar 17, 2026 - 08:53 UTC

Identified

Habitt 20,000 PKR reward is unavailable. We will update as soon as we receive more information.
Posted Mar 13, 2026 - 03:30 UTC
This incident affected: NeoCurrency Rewards.