Order errors due to Cloudfare outage

Incident Report for NeoCurrency

Resolved

Over the last few hours, we have observed zero errors and all the reward links are working fine. Customers can just click the links again to access the rewards.
Posted Nov 19, 2025 - 06:04 UTC

Identified

Some of our brands (reward links) are failing due to Cloudfare outage. We will update here as soon as the issue is resolved.
Posted Nov 18, 2025 - 13:31 UTC
This incident affected: NeoCurrency Rewards.