Nintendo CAD: temporarily unavailable

Incident Report for NeoCurrency

Resolved

Nintendo CAD rewards are working fine now. Customers can just click the reward links again to redeem.
Posted May 07, 2026 - 10:39 UTC

Identified

Nintendo CAD rewards are temporarily unavailable. We will update as soon as the brand is back.
Posted May 06, 2026 - 18:05 UTC
This incident affected: NeoCurrency Rewards.