EGP Brands: temporarily unavailable

Incident Report for NeoCurrency

Resolved

EGP orders are working fine now. Customers can just click the reward links again to redeem.
Posted Sep 15, 2025 - 14:36 UTC

Identified

EGP rewards are temporarily unavailable. We will update as soon as the brands are back.
Posted Sep 14, 2025 - 01:32 UTC
This incident affected: NeoCurrency Rewards.