Douglas DE 20 EUR: discontinued

Incident Report for NeoCurrency

Resolved

Douglas DE 20 EUR denomination has been discontinued. Please remove the denomination from your catalog. Available denominations are 15 and 25 EUR.
Posted Nov 27, 2025 - 05:13 UTC

Identified

Douglas DE 20 EUR denomination is temporarily unavailable. We will update as soon as the denomination is available.
Posted May 02, 2025 - 11:59 UTC
This incident affected: NeoCurrency Rewards.