Bloom & Wild 50 GBP: order errors

Incident Report for NeoCurrency

Resolved

Bloom & Wild 50 GBP orders are working fine now. Customers can just click the reward links again to redeem.
Posted Jun 06, 2025 - 02:35 UTC

Identified

Bloom & Wild 50 GBP orders are failing. We will update as soon as the issue is resolved.
Posted Jun 05, 2025 - 17:34 UTC
This incident affected: NeoCurrency Rewards.