Shahid VIP 3mo 239 EGP: discontinued

Incident Report for NeoCurrency

Resolved

Shahid VIP EGP brand has been discontinued with immediate effect. Kindly remove the brand from your catalog.
Posted Sep 16, 2025 - 12:42 UTC

Identified

Shahid VIP 3mo 239 EGP brand is temporarily out of stock. We will update as soon as the brand is available.
Posted Sep 15, 2025 - 12:14 UTC
This incident affected: NeoCurrency Rewards.