Logan's Roadhouse USD: unavailable

Incident Report for NeoCurrency

Resolved

Logan's Roadhouse USD reward is back. Customers can just click the reward links again to redeem.
Posted Jan 29, 2026 - 15:28 UTC

Identified

Logan's Roadhouse USD reward is unavailable for ordering. Please remove the brand from your catalog.
Posted Jan 02, 2026 - 05:45 UTC
This incident affected: NeoCurrency Rewards.