Razer Gold USD: max denomination update

Incident Report for NeoCurrency

Resolved

This incident has been resolved.
Posted Aug 03, 2026 - 05:56 UTC

Identified

Razer Gold USD reward's maximum denomination has been updated to $200. Available open range is from $10 to $200. Please update your catalog.
Posted Aug 03, 2026 - 05:36 UTC
This incident affected: NeoCurrency Rewards.