Nintendo eShop USD order errors
Incident Report for NeoCurrency
Resolved
Nintendo eShop USD orders are working fine now. Customers can just click the links again to redeem.
Posted Jul 24, 2024 - 05:02 UTC
Investigating
Nintendo eShop USD orders are failing. We are working on the issue and will update as soon as it is resolved.
Posted Jul 16, 2024 - 04:58 UTC
This incident affected: NeoCurrency Rewards.