Neocurrency.com Website and Email Update

Incident Report for NeoCurrency

Resolved

NeoCurrency website and email are working fine now. As always, thank you for your partnership and patience in this matter while we work diligently to get it resolved.
Posted Aug 21, 2025 - 16:05 UTC

Update

We want to share an update regarding the recent disruption to our website and email services.

Due to an error at our hosting provider, our company’s domain and email have been unexpectedly disabled.

This outage is unrelated to NeoCurrency’s core operations or platform and as such it is NOT affecting our YourDigitalReward domain, our dashboard, our API, or our digital reward distribution services.

If you typically access your dashboard account via NeoCurrency.com, please go directly to this link instead:
https://redeem.yourdigitalreward.com/login

We will keep you posted here once this issue has been resolved. As always, thank you for your partnership and patience in this matter while we work diligently to get it resolved.
Posted Aug 21, 2025 - 15:32 UTC

Identified

Neocurrency.com website and email is down. All end user systems are working as normal. Emails directed to neocurrency.com may bounce back until the issue is fixed. We will update as soon as the issue is resolved.
Posted Aug 21, 2025 - 01:10 UTC
This incident affected: NeoCurrency Rewards.