Apple FR EUR order errors
Incident Report for NeoCurrency
Resolved
Apple FR EUR orders are working fine now. Customers can just click the links again to redeem.
Posted Jul 25, 2024 - 18:27 UTC
Investigating
Apple FR EUR orders are failing. We will update as soon as the issue is resolved.
Posted Jul 24, 2024 - 07:36 UTC
This incident affected: NeoCurrency Rewards.