Apple ES and IT EUR order errors
Incident Report for NeoCurrency
Resolved
Apple ES and IT EUR orders are working fine now. Customers can just click the reward links again to redeem..
Posted Jul 29, 2024 - 17:01 UTC
Investigating
Apple ES and IT EUR orders are failing. We will update as soon as the issue is resolved.
Posted Jul 24, 2024 - 09:11 UTC
This incident affected: NeoCurrency Rewards.