Visa Virtual & Mastercard Virtual USD/CAD: maintenance
Incident Report for NeoCurrency
Resolved
This incident has been resolved.
Posted Feb 06, 2024 - 14:16 UTC
Monitoring
Due to the Visa Virtual & Mastercard Virtual USD/CAD digital wallet site maintenance, users might experience intermittent errors on 6 February between 01:30 AM PT and 01:45 AM PT. These errors will be resolved automatically within 24 hours. Users can just click their reward links again to access the cards.
Posted Feb 05, 2024 - 04:25 UTC
This incident affected: NeoCurrency Rewards.