PayPal/Venmo: temporarily unavailable

Incident Report for NeoCurrency

Resolved

PayPal/Venmo brands are available now. Customers can just click the reward links again to redeem.
Posted Aug 27, 2025 - 00:47 UTC

Identified

PayPal/Venmo brands are temporarily unavailable. We will update as soon as the brands are back.
Posted Aug 26, 2025 - 15:23 UTC
This incident affected: NeoCurrency Rewards.