Chatime 25000 IDR: temporarily out of stock

Incident Report for NeoCurrency

Resolved

Chatime 25000 IDR reward is back in stock. Customers can just click the links again to redeem.
Posted Feb 23, 2026 - 10:29 UTC

Identified

Chatime 25000 IDR reward is temporarily out of stock. We will update as soon as the brand is back.
Posted Feb 11, 2026 - 06:32 UTC
This incident affected: NeoCurrency Rewards.