Tim Hortons CAD: orders failing
Incident Report for NeoCurrency
Resolved
Tim Hortons CAD orders are working fine now. Customers can just click the reward links again to redeem.
Posted Feb 06, 2024 - 04:52 UTC
Investigating
Tim Hortons CAD orders are failing. We are working with the brand processor regarding the error and will confirm as soon as it is resolved.
Posted Feb 02, 2024 - 12:16 UTC
This incident affected: NeoCurrency Rewards.