Carrefour TWD: rebranded

Incident Report for NeoCurrency

Resolved

Carrefour TWD has been rebranded to Prosperity Plaza TWD. The brand is now available for ordering. Please update your catalog with the new name.
Posted Jul 09, 2026 - 07:42 UTC

Identified

Carrefour TWD reward is temporarily out of stock. We will update as soon as the brand is back.
Posted Jul 01, 2026 - 03:42 UTC
This incident affected: NeoCurrency Rewards.