Kapruka 1000 LKR: temporarily out of stock

Incident Report for NeoCurrency

Resolved

Kapruka 1000 LKR brand is back in stock. Customers can just click the reward links again to redeem.
Posted May 27, 2025 - 13:46 UTC

Identified

Kapruka 1000 LKR brand is temporarily out of stock. We will update as soon as the denomination is available.
Posted May 23, 2025 - 13:47 UTC
This incident affected: NeoCurrency Rewards.