Lotte Department Store KRW: temporarily unavailable

Incident Report for NeoCurrency

Resolved

Lotte Department Store KRW brand is back. Customers can just click the reward links again to redeem.
Posted Mar 06, 2025 - 04:51 UTC

Identified

Lotte Department Store KRW brand is temporarily discontinued. We will update as soon as the brand is available.
Posted Mar 05, 2025 - 09:19 UTC
This incident affected: NeoCurrency Rewards.