Macy's USD order errors
Incident Report for NeoCurrency
Resolved
Macy's USD orders are working fine now. Customers can just click the links again to redeem.
Posted Jul 24, 2024 - 04:54 UTC
Investigating
Macy's USD orders are failing. We are looking into the issue and will update as soon as it is resolved.
Posted Jul 22, 2024 - 04:21 UTC
This incident affected: NeoCurrency Rewards.