A fix has been implemented and we are seeing the dashboard and API have returned to regular speed
Posted Dec 01, 2025 - 23:12 UTC
Update
We are continuing to see dashboard and API slowness at regular intervals. We are working on resolving the issue and will update soon.
Posted Dec 01, 2025 - 16:01 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Dec 01, 2025 - 11:09 UTC
Identified
We were experiencing server slowness with NeoCurrency Reward Dashboard and API. We are working on the fix and will update as soon as the issue is resolved.
Posted Dec 01, 2025 - 07:58 UTC
This incident affected: NeoCurrency Reward API and NeoCurrency Reward Dashboard.