AUD order errors
Incident Report for NeoCurrency
Resolved
AUD rewards are working fine now. Customers can just click the links again to redeem.
Posted Apr 14, 2024 - 01:06 UTC
Investigating
AUD rewards are failing. We are looking into the issue and will update as soon as it is resolved.
Posted Apr 13, 2024 - 05:41 UTC
This incident affected: NeoCurrency Rewards.