Extra.com BRL: out of stock

Incident Report for NeoCurrency

Resolved

Extra.com BRL brand is back. Customers can just click the reward links again to redeem.
Posted Sep 03, 2025 - 02:30 UTC

Identified

Extra.com BRL brand is temporarily unavailable. We will update as soon as the brand is back.
Posted Sep 02, 2025 - 12:33 UTC
This incident affected: NeoCurrency Rewards.