Apple USD order errors
Incident Report for NeoCurrency
Resolved
Apple USD orders are working fine now. Customers can just click the reward links again to redeem.
Posted Jul 16, 2024 - 04:55 UTC
Investigating
Apple USD orders are failing. We are looking into the issue and will update as soon as it is resolved.
Posted Jul 15, 2024 - 10:46 UTC
This incident affected: NeoCurrency Rewards.