Zattini $30 BRL Rewards: temporarily our of stock
Incident Report for NeoCurrency
Resolved
This incident is resolved. The customers can just click the reward links again to redeem.
Posted Mar 13, 2023 - 03:36 UTC
Update
We are continuing to investigate this issue.
Posted Mar 09, 2023 - 08:18 UTC
Investigating
Zattini $30 BRL Rewards are temporarily our of stock. We will continue to monitor the situation and will reset any failed redemptions once they are back in stock.
Posted Mar 09, 2023 - 08:17 UTC
This incident affected: NeoCurrency Rewards.