Amazon Pay 5000 and 10000 INR: temporarily unavailable

Incident Report for NeoCurrency

Resolved

This incident has been resolved.
Posted May 27, 2025 - 13:48 UTC

Monitoring

Amazon Pay 5000 INR is back. Customers can just click the links again to redeem.
Posted May 09, 2025 - 17:20 UTC

Identified

Amazon Pay 5000 and 10000 INR are temporarily unavailable. We will update as soon as the denominations are back.
Posted May 08, 2025 - 04:31 UTC
This incident affected: NeoCurrency Rewards.