PayPal (USD/CAD/GBP/EUR) and Venmo USD
Incident Report for NeoCurrency
Resolved
PayPal (USD/CAD/GBP/EUR) and Venmo USD rewards are working fine now. Customers can just click the links again to redeem.
Posted Mar 18, 2024 - 02:21 UTC
Investigating
PayPal (USD/CAD/GBP/EUR) and Venmo USD rewards are temporarily unavailable. We will let you know as soon as the rewards are back online.
Posted Mar 17, 2024 - 17:27 UTC
This incident affected: NeoCurrency Rewards.