Amazon JPY order errors
Incident Report for NeoCurrency
Resolved
Amazon JPY orders are working fine now. Customers can just click the reward links again to redeem.
Posted Nov 13, 2024 - 15:30 UTC
Identified
Amazon JPY orders are failing. We have identified the issue and will update as soon as it is resolved.
Posted Nov 13, 2024 - 12:40 UTC
This incident affected: NeoCurrency Rewards.