Lifestyle 100, 250, 500 and 1000 INR are temporarily out of stock. We will update as soon as the denominations are available.
Posted Feb 17, 2025 - 16:29 UTC
Monitoring
Lifestyle 500 and 1000 INR denominations are now available. Customers can just click the reward links again to redeem. Lifestyle 2000 INR is still out of stock. We will update as soon as the denomination is available.
Posted Feb 11, 2025 - 07:38 UTC
Identified
Lifestyle INR is temporarily out of stock. We will update as soon as the brand is available.