Nando GBP: order error

Incident Report for NeoCurrency

Resolved

This incident has been resolved.
Posted Aug 27, 2025 - 09:42 UTC

Identified

Nando GBP orders are failing. We are investigating the issue and will update as soon as it is resolved.
Posted Aug 26, 2025 - 06:36 UTC
This incident affected: NeoCurrency Rewards.